icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

发表于 2016年08月28日 软路由版

一、花生壳
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
local server “http://ddns.oray.com
local domain “域名”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “用户”
local paswd “密码”
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd



二、3322

脚本:


:local ednsuser “用户”
:local ednspass “密码”
:local ednshost “域名”
:local ednsinterface “接口”
:local members “http://members.3322.org/dyndns/update?system=dyndns
#:local members “http://members./nic/update?”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost ;
}
}


本文标题:DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)
本文链接:http://www.zdgsc.com/index.php/post/920.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

9彩注册 www.677298.com-淘全彩票-| www.c15.name-快三容易中奖吗| www.350090.com-什么叫刷水大发快三| www.232355.com-吉林快三出的什么号| www.332619.com-移动梦网彩票频道| www.426405.com-足球彩经-| www.112393.com-福彩三地和值单双| www.789236.com-足彩5808万-| www.880876.com-黑彩网站有没有漏洞| www.953994.com-网上计划彩票| 500彩票www.50024l.com| www.hi99.cc-彩票三军什么意思| www.410775.com-体彩排列三app| www.568564.com-昆明七彩云南怎么去| www.671338.com-乐彩双色球字谜图迷| www.ms03.com-快三选一个号码| www.610638.com-福彩3d天庚图| www.763832.com-手机足彩软件排行榜| www.mk84.com-网上快三输了几十万| www.525046.com-哪个平台有圣地彩| www.608844.com-秒速赛车荣鼎彩| www.688710.com-老谢说彩准不准| www.773607.com-福彩幕后的老总| www.857009.com-中奖几率最大的彩票| www.sp8.com-广西快三奖金规则| www.56wi.com-乐亿彩票幸运快三| www.51862.com-都彩神怎么玩| www.001606.com-福利彩票3d徐柯| www.qj47.com-好彩2复式投注表| www.050715.com-彩票自助机能赚钱吗| www.251070.com-彩票注册邀请码| www.8160.vip-彩票怎么才能中过亿| www.019262.com-官网彩票app下载| www.212931.com-博彩app平台| www.372671.com-网上彩票怎么举报| www.565139.com-河南体彩下载| www.765588.com-93彩票靠谱吗| www.950762.com-信彩app下载| www.i76.club-彩吧论论坛首页| www.791383.com-思乐彩票助手软件| www.975205.com-福利彩票站地址查询| www.8378.cc-济公皇彩网址| www.239923.com-网上买彩票输了几万| www.7040.biz-篮球彩票是否有规律| www.37159.cc-好运来彩票在线| www.056652.com-玩彩票的平台| www.775993.com-利博彩票软件| www.700452.com-大发彩票属于违法| www.875492.com-高频彩拉人返点吗| www.3iz.com-热购彩票合法吗| www.74446.com-中国足彩中心| www.156224.com-彩票兑奖号码查询| www.355480.com-中国福利彩票aop| www.m21.site-快3骰子彩票在哪买| www.55191.cc-时时彩和值确定| www.150507.com-家彩网3d试机号| www.381028.com-福利彩票微信二维码| www.561144.com-体彩历史的今天| www.639608.com-体育彩票足彩申请| www.101419.com-立彩彩票骗局揭秘| www.47372.com-深圳体育彩票官网| www.007041.com-彩票36选7网址| www.092773.com-周口结婚彩礼多少钱| www.173261.com-安微快三开奖结果| www.253133.com-时时彩平台注册| www.325466.com-3d彩票谜语-| www.c85.com-福彩软快三软件下载| www.62mz.com-篮彩推荐网-| www.492382.com-乐彩客彩票可信吗| www.w22.com-诺亚时时彩平台登录| www.75vt.com-秒秒彩合法的吗| www.3163.cm-秒借钱app买足彩| www.17841.cc-彩票纠纷案例| www.882019.com-彩票平台招聘计划师| www.098544.com-彩票有什么软件| www.217336.com-精准彩票中奖软件| www.337625.com-火星彩票快三| www.459905.com-松原800米彩票站| www.566474.com-搜狗彩票官网首页| www.847200.com-竞彩2串1的重要性| 凤凰彩票www.3479a.com| www.2465.com-彩83平台怎么样| www.410323.com-三十六选七彩票开奖| www.586926.com-国际彩票是骗局吗| www.708055.com-3d多彩网字谜图谜| www.902816.com-彩票合买哪个app| 凤凰彩票www.66652c.com| www.ws92.com-彩票路珠开奖网| www.217785.com-彩客彩票旧版本| www.312004.com-合法的彩票网有什么| www.447477.com-吉林快三变化| www.591798.com-七星彩质合是什么| www.708375.com-宝宝人工计划时时彩| www.912708.com-六壬与奇门测彩| 博友彩www.866546.com| www.9zj.cc-体育彩票要怎么选号| www.0371.vip-彩93是正规的吗| www.26300.cc-有人带我玩七星彩| www.78221.cc-福彩3d选号号方法| www.033078.com-彩票438-| www.121506.com-百合娱乐彩票怎么样| www.197869.com-快彩助手官网| www.275984.com-快三假盘-| www.23227.com-河北快三走是图| www.865908.com-深圳熊猫彩票| www.408249.com-中国体育足彩网| www.596422.com-彩票方案软件免费| www.34134.com-福彩三地谜语总汇| www.97722.cc-香港时时彩怎么注册| www.659200.com-35彩票安装-| www.802478.com-中彩手彩票免费下载| www.006.xyz-彩票争霸苹果下载| www.331028.com-那里买彩票走势图图| www.479415.com-福彩大帝-| www.568315.com-黑彩快三-| www.678642.com-彩票注册即送彩金| www.788243.com-许昌彩礼一般多少| www.886335.com-体彩排列三杀码高手| www.rt52.com-买2元彩票中多少钱| www.47fj.com-小白彩票-| www.9558.live-手机在线彩票app| www.nr26.com-京东彩票怎么买| www.914963.com-8k彩票稳赚群| www.hv79.com-快三赢钱技巧规律| www.1fr.com-排列三双彩论坛图谜| www.52ae.com-创意水彩画动物图片| www.0851.date-体彩几点开奖| www.6975.me-彩店宝倒闭了吗| www.16627.cc-万彩网官网-| www.051504.com-高频彩平台推荐| www.e78.cc-体彩金七乐走势图| www.92gr.com-87彩票ios-| www.7626.wang-k彩平台是黑台吗| www.61051.com-百度乐彩彩票可信么| www.150271.com-彩51-| 大众彩票www.984688.com| www.7113.net-彩93彩票苹果版| www.009806.com-北京华彩集团简介| www.128897.com-福利彩票送彩金| www.253897.com-华宇app时时彩| www.925937.com-腾讯彩票app官网| www.0817.net-哪里可以买足彩竞猜| www.40622.com-端彩祥云app链接| www.836710.com-陕西体彩官网| www.930669.com-梦见彩票中大奖| 国彩彩票www.98779.com| www.910097.com-百度乐彩走势图| www.8153.top-澳门博彩讨论qq群| www.088763.com-福彩通有没有挂| www.227872.com-今日福彩开奖结果| www.381533.com-七星彩号码开奖| www.536516.com-七星彩最近50期| www.651070.com-水彩画简单画星空| www.739423.com-众盈彩票-| www.859383.com-河北省福彩中心电话| www.967740.com-郎咸平说彩票| www.ad90.com-凤彩网彩票-| www.32ld.com-福彩书籍-| www.2383.cn-上海福彩15选5| www.590081.com-竞彩官方赔率特点| www.708705.com-大发时时彩爱心彩| www.790060.com-青海福彩投注站| www.me52.com-甘肃快三一定牛今天| www.952001.com-中大奖彩票网下载|